Keluarga Besar Mbah Rakim - Lumajang Kota 16 Juni 2019

Alhamdulillah masih diberi kesempatan berkumpul keluarga meski hanya beberapa jam saja...

31 Agts 2011M/01 Syawal 1432H

Kehadiran KH. Hasyim Muzadi beserta Ibu ke kediaman kami di Klayatan 3 Kota Malang

Desa Tempursari, Lumajang

Tanggal 16 Juni 2019 di Desa Tempursari - Lumajang - Jawa Timur beserta keluarga Besar

Wilayah Gunung Bromo

04 - 05 November 2013 bersama rekan2 di Gunung Bromo

10 Dzulhijjah 1439H

Di masjid besar Abdulloh - Sukun Kota Malang, seusai Sholat Idul Adha 1439H/01 Nov 2017M

Kamis, 10 Februari 2022

Memisah Bandwidth Lokal (IIX) dan Internasional (IX) - Bagian 2

Mulai Mikrotik RouterOS versi 2.9, dikenal dengan fitur yang disebut IP Address List. Fitur ini adalah pengelompokan IP Address tertentu dan setiap IP Address tersebut bisa kita namai. Kelompok ini bisa digunakan sebagai parameter dalam mangle, firewall filter, nat, ataupun queue.

Pengaturan IP Address List

Mikrotik Indonesia telah menyediakan daftar IP Address yang diadvertise di OpenIXP dan IIX, yang bisa didownload dengan bebas di URL: http://www.mikrotik.co.id/getfile.php?nf=nice.rsc

File nice.rsc ini dibuat secara otomatis di server Mikrotik Indonesia setiap jam, dan merupakan data yang telah dioptimalkan untuk menghilangkan duplikasi entri dan tumpang tindih subnet. Saat ini jumlah baris pada script tersebut berkisar 7000 baris.

Contoh isi file nice.rsc : 









Proses pengambilan file nice.rsc bisa dilakukan langsung dari terminal di RouterOS dengan perintah :

/tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc mode=http;

atau bisa juga

/tool fetch url="http://ixp.mikrotik.co.id/download/nice.rsc" mode=http

Kemudian, import-lah file tersebut.

[admin@MikroTik] > import nice.rsc

Opening script file nice.rsc
Script file loaded and executed successfully

Pastikan bahwa proses import telah berlangsung dengan sukses, dengan mengecek Address-List pada Menu IP - Firewall.















Proses upload ini dapat juga dilakukan secara otomatis jika memiliki pengetahuan scripting. Misalnya  membuat shell script pada Linux untuk melakukan download secara otomatis dan mengupload file secara otomatis setiap pk 06.00 pagi. Kemudian tinggal membuat scheduler pada router untuk melakukan import file.

Jika menggunakan RouterOS versi 3.x, proses update juga dapat dilakukan secara otomatis.

Perintah yang perlu dibuat adalah : 

/system sched add comment=�update-nice� disabled=no interval=1d name=�update-nice-rsc� on-event=�:if ([:len [/file find name=nice.rsc]] > 0) do={/file remove nice.rsc }; /tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc mode=http;/import nice.rsc� start-date=jan/01/1970 start-time=06:00:00

atau

/system sched add comment=�update-nice� disabled=no interval=1d name=�update-nice-rsc� on-event=�:if ([:len [/file find name=nice.rsc]] > 0) do={/file remove nice.rsc }; /tool fetch url=http://ixp.mikrotik.co.id src-path=/download/nice.rsc mode=http;/import nice.rsc� start-date=jan/01/1970 start-time=06:00:00

Hati-hati! Setelah copy paste, pastikan hasil copy paste sama persis. Proses copy paste kadang-kadang menghilangkan beberapa karakter tertentu.

Pengaturan Mangle

Langkah selanjutnya adalah membuat mangle. Kita perlu membuat 1 buah connection mark dan 2 buah packet mark, masing-masing untuk trafik internasional dan lokal. 

Untuk rule #0, pastikanlah bahwa Anda memilih interface yang mengarah ke client. Untuk chain, kita menggunakan prerouting, dan untuk kedua packet-mark, kita menggunakan passthrough=no.

/ip firewall mangle

add chain=prerouting in-interface=ether-LAN dst-address-list=nice action=mark-connection new-connection-mark=Koneksi-IIX passthrough=yes

add chain=prerouting connection-mark=Koneksi-IIX action=mark-packet new-packet-mark=Paket-IIX passthrough=no

add chain=prerouting action=mark-packet new-packet-mark=Paket-Internasional passthrough=no







Pengaturan Simple Queue

Untuk setiap client, kita harus membuat 2 buah rule simple queue. Pada contoh berikut ini, kita akan melakukan limitasi untuk IP client 100.10.5.1/24 dan client lain yang terkoneksi dengan port mikrotik kita, dan kita akan memberikan limitasi IIX (up/down) sebesar 512k/10M, dan untuk internasional sebesar (up/down) 512k/5M.

















Pengecekan Akhir

Setelah selesai, lakukanlah pengecekan dengan melakukan akses ke situs lokal maupun ke situs internasional, dan perhatikanlah counter baik pada firewall mangle maupun pada simple queue.






Memisah Bandwidth Lokal (IIX) dan Internasional (IX) - Bagian 1

IX (international eXchange) dan IXP (international eXchange point) IX atau IXP adalah infrastruktur fisik yang memungkinkan penyedia layanan Internet (ISP) dan Jaringan Pengiriman Konten (CDNs) menukar lalu lintas Internet antara jaringan mereka ke international dengan kata lain IX adalah link luar negeri / website / CDN yang berada di luar negeri

IIX singkatan dari Indonesia Internet eXchange. Sedang OpenIXP adalah singkatan dari Open Internet eXchange Point kedua exhange point tersebut berada di jakarta.

IIX atau OpenIXP terdiri dari beberapa ISPs (Internet Service Provider) di seluruh Indonesia. IIX dijalankan oleh organisasi bernama APJII. Sedangkan OpenIXP dijalankan oleh perusahaan datacenter yang bernama IDC (Indonesia Data Center).

Beberapa ISP menawarkan bandwidth yang berbeda antara koneksi IIX dan IX (Internasional) Yang kadang menjadi kebingungan bagi pelanggan dan calon pelanggan adalah pada suatu IP address tujuan apakah termasuk kategori IIX atau IX? Hal ini ditambah lagi dengan ada bandwidth tambahan seperti MCSIX, PGASCOM atau SDIIX yang terkadang dimasukkan dalam jalur IIX ISP. Tambah bingung kan?

ISP juga membantu dengan memberi list IIX++ tapi jumlah nya yang ribuan (bahkan ada yang sampai puluhan ribu), membuat Router SOHO kembang kempis untuk mengimpor dan mengeksekusi list.

Jalur IIX++ itu biasanya digunakan untuk konten yang bersifat CDN. Dalam promosi nya, ISP meng-klaim bahwa youtube tanpa buffer karena lewat jalur IIX++. facebook lebih cepat karena lewat jalur IIX++. Akamai juga lebih cepat, karena juga dihitung lewat IIX++.

Nah, sebagai pelanggan bagaimana mengetahui jalur yang digunakan itu termasuk jalur yang mana? Apa benar youtube dan facebook lewat IIX++?

Secara manual untuk menentukan suatu IP Address termasuk bandwidth mana yang diberikan ISP, salah satu cara nya dengan melalui fungsi traceroute pada mikrotik.

Adakah solusi lain cara menentukan bandwidth dengan tujuan IP address tertentu pada router klien? Tanpa import list dari ISP dan tanpa menggunakan cara manual dengan traceroute. Ada, salah satu dengan pengiriman informasi routing dari ISP ke router pelanggan (BGP peer). Untuk hal ini dapat ditanyakan ke masing-masing ISP yang bersangkutan. Apakah ISP mau mengirim dinamik routing dengan protocol BGP kepada klien nya.

(Sumber : https://www.itbali.org/e-library/apa-itu-ix-dan-iix/ )

Dengan metode queue tree serta menambahkan address list pada setinggan mikrotik dan membagi jaringan menjadi beberapa segmen (VLAN), diharapkan cara ini efektif untuk memanage pemakaian bandwidth disetiap segmen jaringan sehingga setiap user yang terhubung dalam segment jaringan dapat mendapat akses internet sesuai dengan yang ditentukan oleh administrator jaringan. Management bandwidth pemisahan trafik lokal dan internasional melalui address list dengan metode queue tree merupakan salah satu teknik management bandwidth dalam fitur mikrotik yang lebih detail sehingga mampu memaksimalkan alokasi bandwidth, sehingga akan meningkatkan kualitas pelayanan jaringan (Quality of Service)

Bagaimana cara melakukan pemisahan queue untuk trafik internet internasional dan trafik ke internet Indonesia (OpenIXP dan IIX).

Pada artikel ini, diasumsikan bahwa:

  1. Router Mikrotik melakukan Masquerading / src-nat untuk client. Client menggunakan IP privat.
  2. Gateway yang digunakan hanya satu, baik untuk trafik internasional maupun IIX.
  3. Bisa menggunakan web-proxy internal ataupun tanpa web-proxy. Jika menggunakan web-proxy, maka ada beberapa tambahan rule yang perlu dilakukan. Perhatikan bagian NAT dan MANGLE pada contoh.

Jika ada parameter di atas yang berbeda dengan kondisi di lapangan, maka konfigurasi yang ada di artikel ini harus dimodifikasi sesuai dengan konfigurasi network yang ada.

Lanjut Bagian-2


Kamis, 09 Desember 2021

Brosur SMP An-Nur 2022/2023

Penerimaan Peserta Didik Baru di SMP An-Nur Bululawang




Selasa, 19 Oktober 2021

Setting Port PPPoE dan Hotspot Dalam 1 Router D-Link DIR-612

Berikut hasil browsing tentang spesifikasi Router D-Link DIR-612 :

DIR-612 menciptakan jaringan nirkabel rumah berkecepatan tinggi hingga 300 Mbps untuk memenuhi kebutuhan transfer data, web surfing dan game online tanpa gangguan. Antena eksternal meningkatkan jangkauan jaringan nirkabel Anda sehingga Anda dapat menghindari dead spot dan mendapatkan koneksi yang handal di seluruh bagian rumah Anda. DIR-612 juga memiliki fitur Repeater, yang dapat memperluas jangkauan jaringan nirkabel yang ada untuk mencapai sudut terjauh dari rumah atau kantor kecil.

Konektivitas yang fleksibel untuk semua perangkat Anda DIR-612 menjamin koneksi Anda, tidak peduli apakah Anda menggunakan desktop atau laptop PC, smartphone, atau tablet. Empat port Ethernet 10/100 menyediakan konektivitas yang cepat dan handal untuk perangkat kabel Anda, sementara Wireless N300 memungkinkan Anda menghubungkan semua perangkat nirkabel Anda di rumahmu. Anda dapat bermain online dengan game console, melihat video online pada smartphone Anda secara bersamaan Wireless N300 Router memungkinkan Anda mengakses internet dengan semua perangkat Anda. Konektivitas Port Internet dengan kecepatan 10/100 untuk koneksi broadband Internet dengan kecepatan tinggi Empat port LAN 10/100 dapat menghubungkan perangkat melalui kabel Ethernet untuk aktivitas berkecepatan tinggi Teknologi Wireless N untuk meningkatkan kecepatan dan jangkauan, ditambah dengan fitur Repeater Mode untuk memperluas jangkauan wireless Anda

Sistem Keamanan Firewall NAT untuk mengatur lalu lintas data dan menghindari intrusi dari luar Wi-Fi Protected Setup (WPS) memudahkan Anda menambah perangkat ke jaringan Anda secara aman Enkripsi WPA/WPA2 mengamankan jaringan wireless Anda Mudah digunakan Pengaturan melalui web browser

Hanya saja di pasaran ada 2 macam D-Link DIR-612, yang mana saya pribadi juga tidak tahu kenapa ada 2 macam.

Berikut penampakannya pada saat Browsing di mbah google.com

Yang pertama adalah D-Link DIR-612 dengan cat Glossy (kilap), tampak DEPAN & BELAKANG beserta tampilan Web Settingnya









Yang kedua adalah D-Link DIR-612 dengan cat DOFF (buram), tampak DEPAN & BELAKANG beserta tampilan Web Settingnya






Untuk pembahasan Setting Port PPPoE dan Hotspot Dalam 1 Router D-Link DIR-612 yang digunakan adalah D-Link DIR-612 cat DOFF.
Dimana router server menggunakan Mikrotik RB450GX4
Berikut tampilan settingnya dalam bentuk gambar secara umum.



Selasa, 10 Agustus 2021

Setting PPPoE Server di MikroTik

PPPoE itu singkatan dari Point-to-Point-Protocol over Ethernet, termasuk bagian fitur PPP yang ada di router MikroTik. PPPoE merupakan fitur koneksi antara server (mikrotik) dan client melalui ethernet dengan tingkat keamanan yang bagus. PPPoE sangat aman dari netcut karena setiap client membentuk koneksi point to point kepada server gateway (mikrotik) secara private tanpa terhubung ke client lain dibawah router mikrotik yang sama.

Pengertian PPPoE

PPPoE adalah metode koneksi langsung point-to-point antara dua perangkat jaringan melalui ethernet secara tunnel dan bersifat pribadi,  sehingga layanan pppoe dapat menyediakan otenkasi (client butuh login, butuh dial-up ke server untuk mendapatkan koneksi), transmisi data terenkripsi dan terkompresi. Pada sistem layanan PPPoE, setiap koneksi yang terbentuk antara server dan client akan membentuk virtual interface dibawah ethernet pelayan.

Fungsi dan Kegunaan PPPoE

Sistem PPPoE banyak dipakai pada distribusi jaringan WAN atau MAN seperti ISP, mini ISP, RTRW NET, Desa NET. PPPoE begitu banyak dipakai oleh para network engineer. Hal ini disebabkan karena link yang dibangun dengan protokol PPPoE adalah jauh lebih aman dari pada distribusi menggunakan Static IP dan DHCP Server biasa dan juga Hotspot. Kalau saya list kan fungsi dan manfaat pppoe adalah sebagai berikut: 

  • Sarana sharing internet alternatif selain hotspot 
  • Sarana distribusi jaringan internet dari ISP ke client permanen / client bayar bulanan, kalau hotspot untuk client yang beli voucher harian, per jam, atau perminggu 
  • Mendukung lalu-lintas data tak terbatas / unlimited transfer rate
  • Mudah dalam pembagian bandwidth per user 
  • Sangat aman dari netcut dan aman dari tools hacking tanpa pusing dengan rule firewall 
  • PPPoE tidak membutuh DHCP server, namun boleh pakai ip-pool kalau Anda ingin client mendapatkan ip dinamis melalui profiles, atau client akan mendapat ip static dengan menentukan local address dan remote address (baca bagian setting dibawah ini)dan lain-lain

Cara Membuat PPPoE Server di MikroTik

Langkah pertama, buatlah pppoe server Mikrotik pada interface yang mengarah ke client. Misalnya menggunakan interface ether5. Lakukan konfigurasi via Winbox seperti berikut :

  • Klik PPP
  • Kemudian klik +
  • Service Name : pppoe
  • interface: pilih ethernet yg dipakai hotspot server, contoh:  ether5
  • centang pada One Session Per Host
  • simpan dengan klik Apply dan OK































    Langkah kedua, membuat profiles ppp : 
  •     klik tab profiles
  •     klik +
  •     pada General isi kolom Name : paket 1Mbps atau paket 2Mbps



















    pada tab protocol, use compression: yes, use encription : yes, sisanya default saja.













    selanjutnya klik tab Limits :
  •     tentukan Rate Limit (rx/tx), rx adalah upload, tx adalah download, 
  •     satuannya k untuk Kbps, dan M untuk Mbps.
  •     Only one pilih yes untuk limit session. 
  •     Klik Apply dan OK



















Langkah ketiga, tentukan user dan password untuk client yang ingin terhubung ke Mikrotik menggunakan pppoe. 
Masuk tab Secrets pada menu PPP kemudian anda tentukan user name, password, pilih profile yang udah dibuat, sebaiknya tiap user dibuat berbeda local address dan remote addressnya



Jika client sudah berhasil terhubung / login pppoe sukses, Anda bisa lihat status client di winbox pada menu PPP  Active Connections 























Apabila sudah client berhasil dial-up ke server, maka tinggal bikin NAT, caranya :
klik menu IP 
 Firewall  NAT
klik +
Tab General
  - chain = srcnat
  - src. address = 50.10.5.0/24
Tab Action
  - action = masquerade



Minggu, 16 Mei 2021

Tentang robots.txt

Robots.txt terkait sangat erat dengan suksesnya sebuah strategi SEO. Dengan menggunakan file robots.txt, bot mesin pencari dapat berinteraksi secara lebih baik dengan website yang Anda kelola. Untuk memahami apa dan bagaimana robots.txt, kita akan membahasnya satu persatu pada artikel ini.

Apa itu robots.txt?

Secara sederhana robots.txt adalah rangkaian file berbentuk text yang berisi instruksi kepada mesin pencari seperti Google. Dengan memberikan robots.txt pada website maka website akan memberikan tanda kepada Google ke mana saja akses yang harus dilakukan dan halaman mana saja yang perlu diindeks.

Oleh karena itu, robots.txt akan membuat artikel website lebih mudah dan lebih cepat diindeks di mesin pencari seperti Google. Sehingga, peringkat halaman artikel Anda akan lebih cepat naik di halaman hasil pencarian Google. Robots.txt juga dapat memisahkan halaman yang tidak ingin Anda tampilkan di dalam mesin pencari. Fungsi lain dari file ini juga untuk menghalangi beberapa mesin pencari melakukan crawl ke website Anda sehingga beban website akan tetap terjaga.

File robots.txt terletak di dalam folder root server penyimpanan situs yang biasa disebut sebagai folder public_html. Namun file ini adalah file virtual yang tidak dapat diakses ataupun diganti melalui direktori manapun. Sehingga, ketika Anda ingin memperbarui file ini, Anda harus membuat sendiri file robots.txt yang diletakan di dalam folder public_html dan memasukan skrip konfigurasi secara manual.

Konfigurasi robots.txt

Konfigurasi robots.txt termasuk cukup sederhana karena hanya berisi beberapa instruksi saja. Berikut ini adalah contoh konfigurasi file robots.txt.

User-agent: *

Disallow: /cgi-bin

Disallow: /wp-admin

Disallow: /wp-includes

Disallow: /wp-content

User-agent: Bingbot

Diasallow: /

Kode robot.txt diawali dengan teks user-agent: * dan diikuti oleh kode dari bot yang akan menunjukan dan menerapkan pengaturan website. Tanda bintang (*) setelah teks user_agent dapat diartikan sebagai pengaturan universal

Misalkan Anda ingin menambahkan atau mengizinkan beberapa mesin pencari untuk melakukan crawl, Anda cukup menambahkan beberapa baris skrip seperti di bawah ini.

User-agent: Mediapartners-Google

Allow: /

User-agent: Adsbot-Google

Allow: /

User-agent: Googlebot-Mobile

Allow: /

Sitemap: www.area27b.net/sitemap.xml

User-agent adalah instruksi yang digunakan untuk mendeskripsikan rule jenis/nama robot. Allow untuk menambahkan bagian mana yang dapat diakses oleh robot, dan disallow untuk mendeskripsikan bagian yang tidak boleh diakses oleh robot. Jika tidak terdapat skrip disallow: maka mesin pencari dapat memindai keseluruhan isi website.

Dengan menggunakan skrip diatas, Anda akan mengarahkan mesin pencari untuk memindai isi dari sebuah website. Sebagai contoh, jika website yang Anda kelola memiliki beberapa image yang tidak ingin terbaca oleh Google maka Anda dapat membuat skrip disallow: /images/ (disallow folder images) untuk memberikan instruksi kepada Google agar tidak memindai gambar tersebut.

  • Disallow: [Setidaknya satu atau beberapa entri Disallow atau Allow per aturan] Direktori atau halaman, yang terkait dengan domain root, yang tidak ingin di-crawl agen pengguna. Jika aturan mengacu pada halaman, nama tersebut harus berupa nama halaman lengkap seperti yang ditampilkan di browser; jika merujuk ke direktori, seharusnya diakhiri dengan tanda /.
  • Allow: [Minimal satu atau beberapa entri Disallow atau Allow per aturan] Direktori atau halaman, yang terkait dengan domain root, yang mungkin di-crawl oleh agen pengguna sebagaimana disebutkan di artikel bantuan ini. Ini digunakan untuk mengganti perintah Disallow guna mengizinkan crawling subdirektori atau halaman dalam direktori yang tidak diizinkan. Untuk satu halaman, nama halaman lengkap seperti yang ditampilkan di browser harus ditentukan. Untuk direktori, aturan harus diakhiri dengan tanda /.
  • Sitemap: [Opsional, nol atau lebih per file] Lokasi peta situs untuk situs ini. URL peta situs harus berupa URL yang sepenuhnya memenuhi syarat; Google tidak menganggap atau memeriksa alternatif http/https/www.non-www. Peta situs adalah cara yang tepat untuk menunjukkan konten mana yang boleh di-crawl oleh Google, bukan konten mana yang dapat atau tidak dapat di-crawl. Contoh:

Sitemap: https://example.com/sitemap.xml

Sitemap: http://www.example.com/sitemap.xml

Semua perintah, kecuali sitemap, mendukung karakter pengganti * untuk awalan jalur akhiran, atau string secara keseluruhan.

Baris yang tidak cocok dengan perintah ini akan diabaikan.

Contoh file lainnya

File robots.txt terdiri dari satu atau beberapa grup, yang masing-masing diawali dengan baris User-agent yang menentukan target dari grup tersebut. Berikut adalah sebuah file dengan dua grup; komentar inline menjelaskan setiap grup:

# Block googlebot from example.com/directory1/... and example.com/directory2/...

# but allow access to directory2/subdirectory1/...

# All other directories on the site are allowed by default.

User-agent: googlebot

Disallow: /directory1/

Disallow: /directory2/

Allow: /directory2/subdirectory1/


# Block the entire site from anothercrawler.

User-agent: anothercrawler

Disallow: /

Harap baca seluruh dokumentasi tersebut karena ada beberapa hal rumit dan penting untuk dipelajari pada sintaksis robots.txt.

 

Rabu, 31 Maret 2021

Protected Page pada Halaman Blog

Suatu halaman pada situs blogspot yang kita buat bisa dibuka/dibaca dengan syarat mengisi Password atau Kata Kunci yang dalam bahasa Inggris disebut "Protected Page". Artinya, halaman atau postingan diberikan pengamanan berupa password (kata sandi), sehingga hanya pengunjung tertentu yang bisa mengakses atau membukanya.








Caranya dapat dicoba sebagai berikut :

  1. Buat halamannya: klik menu Pages > New Page
  2. Silakan isi dulu halamannya, hingga selesai.
  3. Klik mode "HTML"
  4. Copas kode berikut ini di dalamnya, di bagian paling bawah atau paling atas (sebelum atau sesudah isi halaman).
  5. Ganti tulisan warna MERAH dengan password yang anda inginkan


<script language="JavaScript">

var password;

var pass1="PASSWORD";

 

Jumat, 19 Februari 2021

IP Hotspot Sudah Penuh 254 IP Address

Ambil perumpamaan :


Di mikrotik menggunakan : IP Pool hotspot dari 10.5.50.2 – 10.5.50.254 dan IP address yang di gunakan 10.5.50.1/24

Dalam aplikasi di lapangan penggunaan IP 10.5.50.xxx ternyata sudah penuh karena banyak user yang daftar menjadi anggota hotspot wifi kita.

Dalam 1 username & password di share sebanyak 4 perangkat. Dan yang daftar jadi klien kita ada sekitar 60. Sedangkan klien voucher kita target sekitar 100 voucher yang disebarkan.

Maka (60 x 4) + 100 = 340 klien yang aktif. Bisa dipastikan IP Hotspot yang hanya berjumlah 254 akan kelebihan lokasi sekitar 86.

Solusinya : 

  1. Dengan menganti IP Address menjadi 10.5.50.1/23. Lalu poolnya lebarkan, kalo /23 jadinya adalah 10.5.50.2 – 10.5.51.254. Dengan begini kita dapat 510 ip address.
  2. Dengan mengaktifkan Next Pool pada IP Pool Hotspot
  3. Atau dengan script seperti dibawah ini :

Untuk menghemat IP Pool, logikanya adalah dengan membersihkan DHCP lease agar IP Pool menjadi lebih hemat. Buat sebuah scheduler (System → Scheduler) dengan interval cocok yang diinginkan (sebagai contoh, script ini dilaksanakan tiap-tiap 6 jam sekali), lalu copy & paste script di bawah ini pada anggota source.

# Make Static Lease for Active Hotspot

:log warning message=(“[START] * CLEAN UP DYNAMIC DHCP LEASE *”);

:foreach z in=[/ip hotspot active find] do={

:local u ([/ip hotspot active get $z user]);

:local m ([/ip hotspot active get $z mac-address]);

:local a ([/ip hotspot active get $z address]);

/ip dhcp-server lease make-static [/ip dhcp-server lease find mac-address=$m];

/ip dhcp-server lease comment [find mac-address=$m] $u;

};

# Clean Dynamic Lease and Waiting Status

/ip dhcp-server lease remove [find dynamic]

/ip dhcp lease remove [find where status=waiting]

:log warning message=(“[END] * CLEAN UP DYNAMIC DHCP LEASE *”);

Setelah di paste, klik Apply lalu klik OK. Dengan demikian script ini dapat melakukan bersih-bersih secara berkala cocok dengan interval yang telah ditentukan.


Kamis, 18 Februari 2021

Rumus pada Bangun Datar di Microsoft Excel-2 (Segitiga Siku -Siku)

Segitiga siku-siku adalah segitiga di mana satu sudut adalah sudut kanan (yaitu, sudut 90 derajat). Hubungan antara sisi dan sudut segitiga siku-siku adalah dasar untuk trigonometri.

sumber : https://id.wikipedia.org/wiki/Segitiga_siku-siku


Sisi yang berseberangan dengan sudut kanan disebut hypotenuse (sisi c pada gambar). Sisi-sisi yang berdekatan dengan sudut kanan disebut kaki (atau catheti, singular: cathetus). Sisi a dapat diidentifikasi sebagai sisi yang berdekatan dengan sudut B dan berlawanan dengan (atau berlawanan) sudut A, sedangkan sisi b adalah sisi yang berdekatan dengan sudut A dan berlawanan dengan sudut B.

Jika panjang ketiga sisi dari segitiga siku-siku adalah bilangan bulat, segitiga tersebut disebut segitiga Pythagoras dan panjang sisinya secara kolektif dikenal sebagai triple Pythagoras.

Dalam matematika, teorema Pythagorean, juga dikenal sebagai teorema Pythagoras, adalah hubungan mendasar dalam geometri Euclidean di antara tiga sisi segitiga siku-siku. Ini menyatakan bahwa luas kotak yang sisinya adalah sisi miring (sisi yang berlawanan dengan sudut kanan) sama dengan jumlah area kotak di dua sisi lainnya. Teorema ini dapat ditulis sebagai persamaan yang menghubungkan panjang sisi a, b dan c, sering disebut "persamaan Pythagoras"

di mana c mewakili panjang sisi miring dan a dan b panjang dari dua sisi segitiga lainnya. Teorema itu, yang sejarahnya menjadi pokok perdebatan, dinamai untuk pemikir Yunani kuno Pythagoras.

Teorema ini telah diberikan banyak bukti - mungkin yang paling banyak untuk setiap teorema matematika. Mereka sangat beragam, termasuk bukti geometris dan bukti aljabar, dengan beberapa berasal dari ribuan tahun yang lalu. Teorema dapat digeneralisasi dalam berbagai cara, termasuk ruang dimensi tinggi, ke ruang yang bukan Euclidean, ke objek yang bukan segitiga siku-siku, dan memang, untuk objek yang bukan segitiga sama sekali, tetapi padatan n-dimensi. Teorema Pythagoras telah menarik minat di luar matematika sebagai simbol kemustahilan matematika, mistik, atau kekuatan intelektual; referensi populer dalam sastra, drama, musikal, lagu, perangko dan kartun berlimpah.

sumber : https://id.wikipedia.org/wiki/Teorema_Pythagoras

Berikut ini akan dibuat tutorial membuat penghitungan pada bangun segitiga siku-siku yaitu mencari sisi miring dan menghitung Keliling dan Luasnya.

  • Keliling = sisi A + sisi B + sisi C
  • Luas     = (Alas X Tinggi)/2
  • Untuk mencari sisi Miring pada segitiga Siku-siku Dipergunakan Teorema Phytagoras yaitu : Sisi Miring = Akar dari (Kuadrat Sisi Tegak + Kuadrat Sisi Alas
Untuk lebih jelasnya bisa melihat video dibawah ini :




Selamat mencoba & semoga sukses...

Selasa, 16 Februari 2021

Rumus pada Bangun Datar di Microsoft Excel-1 (Persegi dan Persegi Panjang)

Microsoft Excel atau Microsoft Office Excel adalah sebuah program aplikasi lembar kerja yang dibuat dan didistribusikan oleh Microsoft Corporation yang dapat dijalankan pada Microsoft Windows dan Mac OS. Aplikasi ini merupakan bagian dari Microsoft Office System. Aplikasi ini memiliki fitur kalkulasi dan pembuatan grafik yang, dengan menggunakan strategi marketing Microsoft yang agresif, menjadikan Microsoft Excel sebagai salah satu program komputer yang populer digunakan di dalam komputer mikro hingga saat ini. Bahkan, saat ini program ini merupakan program spreadsheet paling banyak digunakan oleh banyak pihak, baik di platform PC berbasis Windows maupun platform Macintosh berbasis Mac OS, semenjak versi 5.0 diterbitkan pada tahun 1993.


Sejarah : Pada tahun 1982, Microsoft membuat sebuah program spreadsheet yang disebut dengan Multiplan, yang sangat populer dalam sistem-sistem CP/M, tetapi tidak dalam sistem MS-DOS mengingat di sana sudah berdiri saingannya, yakni Lotus 1-2-3. Hal ini membuat Microsoft memulai pengembangan sebuah program spreadsheet yang baru yang disebut dengan Excel, dengan tujuan, seperti yang dikatakan oleh Doug Klunder, "do everything 1-2-3 does and do it better/melakukan apa yang dilakukan oleh 1-2-3 dan lebih baik lagi".

Versi pertama Excel dirilis untuk Macintosh pada tahun 1985 dan versi Windows-nya menyusul (dinomori versi 2.0) pada November 1987. Lotus ternyata terlambat turun ke pasar program spreadsheet untuk Windows, dan pada tahun tersebut, Lotus 1-2-3 masih berbasis MS-DOS. Pada tahun 1988, Excel pun mulai menggeser 1-2-3 dalam pangsa pasar program spreadsheet dan menjadikan Microsoft sebagai salah satu perusahaan pengembang aplikasi perangkat lunak untuk komputer pribadi yang andal. Prestasi ini mengukuhkan Microsoft sebagai kompetitor yang sangat kuat bagi 1-2-3 dan bahkan mereka mengembangkannya lebih baik lagi. Microsoft, dengan menggunakan keunggulannya, rata-rata merilis versi Excel baru setiap dua tahun sekali, dan versi Excel untuk Windows terakhir adalah Microsoft Office Excel 2010 (Excel 14), sementara untuk Macintosh (Mac OS X), versi terakhirnya adalah Excel for Mac.

Pada awal-awal peluncurannya, Excel menjadi sasaran tuntutan perusahaan lainnya yang bergerak dalam bidang industri finansial yang telah menjual sebuah perangkat lunak yang juga memiliki nama Excel. Akhirnya, Microsoft pun mengakhiri tuntutan tersebut dengan kekalahan dan Microsoft harus mengubah nama Excel menjadi "Microsoft Excel" dalam semua rilis pers dan dokumen Microsoft. Meskipun demikian, dalam praktiknya, hal ini diabaikan dan bahkan Microsoft membeli Excel dari perusahaan yang sebelumnya menuntut mereka, sehingga penggunaan nama Excel saja tidak akan membawa masalah lagi. Microsoft juga sering menggunakan huruf XL sebagai singkatan untuk program tersebut, yang meskipun tidak umum lagi, ikon yang digunakan oleh program tersebut masih terdiri atas dua huruf tersebut (meski diberi beberapa gaya penulisan). Selain itu, ekstensi default dari spreadsheet yang dibuat oleh Microsoft Excel hingga versi 11.0 (Excel 2003) adalah *.xls sedangkan mulai Microsoft Office Excel 2007 (versi 12.0) ekstensi default-nya adalah *.xlsx yang mendukung format HTML namun dengan isi yang sama memiliki ukuran file yang lebih kecil jika dibandingkan dengan versi-versi Excel sebelumnya.

Excel menawarkan banyak keunggulan antar muka jika dibandingkan dengan program spreadsheet yang mendahuluinya, tetapi esensinya masih sama dengan VisiCalc (perangkat lunak spreadsheet yang terkenal pertama kali): Sel disusun dalam baris dan kolom, serta mengandung data atau formula dengan berisi referensi absolut atau referensi relatif terhadap sel lainnya.
Excel merupakan program spreadsheet pertama yang mengizinkan pengguna untuk mendefinisikan bagaimana tampilan dari spreadsheet yang mereka sunting: font, atribut karakter, dan tampilan setiap sel. Excel juga menawarkan penghitungan kembali terhadap sel-sel secara cerdas, di mana hanya sel yang berkaitan dengan sel tersebut saja yang akan diperbarui nilanya (di mana program-program spreadsheet lainnya akan menghitung ulang keseluruhan data atau menunggu perintah khusus dari pengguna). Selain itu, Excel juga menawarkan fitur pengolahan grafik yang sangat baik.
Ketika pertama kali dibundel ke dalam Microsoft Office pada tahun 1993, Microsoft pun mendesain ulang tampilan antar muka yang digunakan oleh Microsoft Word dan Microsoft PowerPoint untuk mencocokkan dengan tampilan Microsoft Excel, yang pada waktu itu menjadi aplikasi spreadsheet yang paling disukai.

Sejak tahun 1993, Excel telah memiliki bahasa pemrograman Visual Basic for Applications (VBA), yang dapat menambahkan kemampuan Excel untuk melakukan automatisasi di dalam Excel dan juga menambahkan fungsi-fungsi yang dapat didefinisikan oleh pengguna (user-defined functions/UDF) untuk digunakan di dalam worksheet. Dalam versi selanjutnya, bahkan Microsoft menambahkan sebuah integrated development environment (IDE) untuk bahasa VBA untuk Excel, sehingga memudahkan programmer untuk melakukan pembuatan program buatannya. Selain itu, Excel juga dapat merekam semua yang dilakukan oleh pengguna untuk menjadi macro, sehingga mampu melakukan automatisasi beberapa tugas. VBA juga mengizinkan pembuatan form dan kontrol yang terdapat di dalam worksheet untuk dapat berkomunikasi dengan penggunanya. Bahasa VBA juga mendukung penggunaan DLL ActiveX/COM, meski tidak dapat membuatnya. Versi VBA selanjutnya menambahkan dukungan terhadap class module sehingga mengizinkan penggunaan teknik pemrograman berorientasi objek dalam VBA.

Fungsi automatisasi yang disediakan oleh VBA menjadikan Excel sebagai sebuah target virus-virus macro. Ini merupakan problem yang sangat serius dalam dunia korporasi hingga para pembuat antivirus mulai menambahkan dukungan untuk mendeteksi dan membersihkan virus-virus macro dari berkas Excel. Akhirnya, meski terlambat, Microsoft juga mengintegrasikan fungsi untuk mencegah penyalahgunaan macro dengan menonaktifkan macro secara keseluruhan, atau menngaktifkan macro ketika mengaktifkan workbook, atau mempercayai macro yang dienkripsi dengan menggunakan sertifikat digital yang tepercaya.

Membuat perhitungan sederhana dengan menggunakan MS Excel sebagai salah satu contoh adalah menghitung Keliling dan Luas Bangun Datar.

1. Pada bagian pertama adalah menghitung Keliling dan Luas bangun Persegi


2. Bagian kedua menghitung Keliling dan Luas Segitiga Siku-Siku